[ Foro de Pseudocódigo ]

Ejercicio propuesto 9.2: Error PSeInt

11-Feb-2019 01:28
Invitado (Anon)
2 Respuestas

Ejercicio de repaso propuesto 9.2: Haz un programa que pida al usuario 5 datos, los guarde en una matriz y luego muestre su media (la suma de los 5 datos, dividida entre 5).

Creo haber echo el ejercicio correctamente, aquí el código:

Algoritmo EjercicioMatrices9.2

Dimension datos[5];
definir datos, suma como entero;
definir media como real;
suma <- 0;
definir i como entero;

para i <- 0 hasta 4 con paso 1 hacer
escribir "Escriba un número: ", i+1;
leer datos[i];
FinPara

Para i <- 0 hasta 4 con paso 1 Hacer
suma <- suma + datos[i];
FinPara

Escribir "La suma de los números es: ", suma;
media <- suma/5;
escribir "El promedio es: ", media;

FinAlgoritmo

Sin embargo, PSeInt me muestra el siguiente error:

Lin 11 (inst 1): ERROR 303: Subindice (0) fuera de rango
(1...5

ERROR 303: Subindice (0) fuera de rango (1...5)
No se encontro descripción para este error

¿Cúal es el problema?


11-Feb-2019 08:35
Nacho Cabanes (+40)

¿Qué perfil de sintaxis tienes puesto? ¿Puede ser que te esté numerando de 1 a 5, no de 0 a 4?


11-Feb-2019 12:14
Invitado (Anon)

Gracias, ya he solucionado el problema. Por si acaso dejo como lo he echo:

Algoritmo Ejercicio002

Dimension datos[5];
definir datos, suma como entero;
definir media como real;
suma <- 0;
definir i como entero;

para i <- 1 hasta 5 con paso 1 hacer
escribir "Escriba un número: ";
leer datos[i];
FinPara

Para i <- 1 hasta 5 con paso 1 Hacer
suma <- suma + datos[i];
FinPara

Escribir "La suma de los números es: ", suma;
media <- suma/5;
escribir "El promedio es: ", media;

FinAlgoritmo






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)