[ Foro de Pseudocódigo ]

Alguien me ayuda!!!!

31-Jul-2020 04:00
Invitado (Pseint)
3 Respuestas

Realizar un algoritmo que permita realizar una encuesta sobre la bebida de preferencia. El algoritmo deberá mostrar tres opciones al encuestado:
1-pepsi
2-gallito
3-fioravanti
La persona a quien se le realiza la encuesta deberá elegir por una de esas opciones, al final deberá mostrar indicar el nombre del encuestado y la bebida de preferencia, en caso de que la persona haya ingresado un dato diferente a los de las opciones mostrar un mensaje de que la respuesta presentaba errores.


22-Aug-2020 17:08
Invitado (RAUL EACO REYES BUENO)

MIRA SI TE SIRVE..


Algoritmo encuesta
			
	a<-minusculas(a);
	Escribir "ELIGE UNA BEBIDA : (1-3)";
	Escribir "1-pepsi";
	Escribir "2-gallito";
	Escribir "3-fioravanti";
	Leer a;
	
	Escribir "NOMBRE :";
	Leer b;
	
	Si a=="1" Entonces
		Escribir b," ELIGIO PEPSI.";
	SiNo
		Si a=="2" Entonces
			Escribir b," ELIGIO GALLITO.";
		SiNo
			Si a=="3" Entonces
				Escribir b," ELIGIO FLORAVANTI.";
			SiNo
				Escribir b," ELIGE DEL 1 AL 3..";
			Fin Si	
		Fin Si	
	Fin Si
	
FinAlgoritmo


 


22-Aug-2020 18:20
Invitado (Hola logre resolver tu problema, se que hay formas mas elega)




usuario = input("  ¿Cual es tu nombre?: ")
bebida = int(input("""
  ¿Cual es tu bebida preferida?

  1. Pepsi
  2. Gallito
  3. Fioravanti
  
"""))

P = "Pepsi"
G = "Gallito"
F = "Fioravanti"


if bebida == 1:
    print("Nombre: ", usuario)
    print("Bebida preferida: ", P)
elif bebida == 2:
    print("Nombre: ", usuario)
    print("Bebida preferida: ", G)
elif bebida == 3:
    print("Nombre: ", usuario)
    print("Bebida preferida: ", F)
else:
    print("Esa opcion no existe, por favor vuelva a intentarlo")




22-Aug-2020 18:31
Anderson Herrera

Hola logre solucionar tu problema de la manera mas sencilla para que la entiendas.


usuario = input("  ¿Cual es tu nombre?: ") #Cuando el usuario escriba algo, se guardara en la variable usuario
bebida = int(input("""
  ¿Cual es tu bebida preferida?

  1. Pepsi
  2. Gallito
  3. Fioravanti
  
"""))                 #fíjate que como el usuario va a introducir numero hay que poner int(input(""))

P = "Pepsi"  #Declaramos una variable de texto con el nombre de cada bebida
G = "Gallito"
F = "Fioravanti"


if bebida == 1:  #La condición es que si bebida(el numero que inserte el usuario) es igual(==)  a 1 cumpla con los siguiente.
    print("Nombre: ", usuario) #Imprime nombre + usuario(lo que haya escrito al principio)
    print("Bebida preferida: ", P) #Imprime Bebida preferida + una de las 3 opciones, P, G o F.

elif bebida == 2:
    print("Nombre: ", usuario)
    print("Bebida preferida: ", G)

elif bebida == 3:
    print("Nombre: ", usuario)
    print("Bebida preferida: ", F)
else:                                                        # Pero si el numero que inserta no esta en las opciones ejecuta esto:
    print("Esa opción no existe, por favor vuelva a intentarlo")


 






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...