Cursos gratuitos de programacion de ordenadores, en español

AnteriorPosterior

11 - Ejercicios resueltos

  Curso: Introducción a la programación - Pseudocódigo

11 - Ejercicios resueltos

a) Enunciados

1.- Crear un algoritmo que escriba "Hola" cinco veces.

2.- Crear un algoritmo que pida al usuario un número y le diga si es positivo, negativo o cero.

3.- Crear un algoritmo que pida al usuario 5 datos y muestre su suma.

4.- Crear un algoritmo que calcule la raíz cuadrada del número que introduzca el usuario. Si se introduce un número negativo, debe mostrar un mensaje de error y volver a pedirlo (tantas veces como sea necesario).

5.- Crear un algoritmo que pida al usuario un número y un símbolo, y dibuje un cuadrado usando ese símbolo. El cuadrado tendrá el tamaño que ha indicado el usuario. Por ejemplo, si el usuario introduce 4 como tamaño y * como símbolo, deberá escribirse algo como:

****
****
****
****


b) Ejemplos de soluciones con PseInt

1.- Crear un algoritmo que escriba "Hola" cinco veces.

// 1.- Crear un algoritmo que escriba "Hola" cinco veces.
 
Proceso Resuelto01
  Para x <- 1 Hasta 5 Hacer
    Escribir "Hola";
  FinPara
FinProceso 

2.- Crear un algoritmo que pida al usuario un número y le diga si es positivo, negativo o cero.

// 2.- Crear un algoritmo que pida al usuario un numero y le diga si es positivo, negativo o cero.
 
Proceso Resuelto02
  Escribir "Dime un numero";
  Leer x;
  Si x > 0 Entonces
    Escribir "Es positivo";
  Sino
    Si x < 0 Entonces
      Escribir "Es negativo";
    Sino
      Escribir "Es cero";
    FinSi
  FinSi
FinProceso 
 

3.- Crear un algoritmo que pida al usuario 5 datos y muestre su suma.

// 3.- Crear un algoritmo que pida al usuario 5 datos y muestre su suma.
// Forma (a), sin usar matrices
 
Proceso Resuelto03
  suma <- 0
  Para x <- 1 Hasta 5 Hacer
    Escribir "Dime un dato";
    Leer x;
    suma <- suma + x;
  FinPara
  Escribir "Su suma es ", suma;
FinProceso 

o de forma alternativa, usando matrices:

// 3.- Crear un algoritmo que pida al usuario 5 datos y muestre su suma.
// Forma (b), usando matrices
 
Proceso Resuelto03
 
  Dimension dato[5]
 
  Para x <- 1 Hasta 5 Hacer
    Escribir "Dime un dato";
    Leer dato[x];
  FinPara
 
  suma <- 0
 
  Para x <- 1 Hasta 5 Hacer
    suma <- suma + dato[x];
  FinPara
 
  Escribir "Su suma es ", suma;
FinProceso 

4.- Crear un algoritmo que calcule la raíz cuadrada del número que introduzca el usuario. Si se introduce un número negativo, debe mostrar un mensaje de error y volver a pedirlo (tantas veces como sea necesario).

// 4.- Crear un algoritmo que calcule la raíz cuadrada del número 
// que introduzca el usuario. Si se introduce un número negativo, 
// debe mostrar un mensaje de error y volver a pedirlo 
// (tantas veces como sea necesario).
 
Proceso Resuelto04
 
  Repetir
    Escribir "Dime un numero";
    Leer x;
    Si x < 0 Entonces
      Escribir "No puede ser negativo";
    FinSi
  Hasta Que x >= 0
 
  Escribir "Su raiz es ", rc(x);
 
FinProceso 
 

5.- Crear un algoritmo que pida al usuario un número y un símbolo, y dibuje un cuadrado usando ese símbolo. El cuadrado tendrá el tamaño que ha indicado el usuario.

(No funcionará correctamente en versiones de PseInt anteriores a agosto de 2011)

// 5.- Crear un algoritmo que pida al usuario un número y un símbolo, 
// y dibuje un cuadrado usando ese símbolo. El cuadrado tendrá el tamaño 
// que ha indicado el usuario.
 
// No funciona con versiones de PseInt de antes de Agosto de 2011,
// porque las versiones previas a la 20110801 no permiten escribir
// sin avanzar de linea
 
Proceso Resuelto05
  Escribir "Dime el lado";
  Leer lado;
 
  Escribir "Dime el simbolo de relleno";
  Leer simbolo;
 
  Para fila<-1 Hasta lado Hacer
 
    Para columna <- 1 Hasta lado Hacer
      Escribir Sin Saltar simbolo ; // Escribir sin bajar de línea
    FinPara
 
    Escribir "";  // Avance de línea tras cada fila
  FinPara
 
FinProceso 
 

Actualizado el: 29-12-2013 00:56

AnteriorPosterior